System Requirements

To utilize the LMS properly, there are certain basic system requirements that need to be met:

  • JavaScript is enabled
  • Cookies are accepted
  • Flash is enabled*

*Flash could potentially be needed to view videos and webinars. We are working to replace these videos with a more flexible format. 

Recommended Browsers:

It is always a good idea to keep your browsers up to date. You can check which browser version you are using with the following tool: What is my browser, and is it up-to-date?

The following browser versions have been tested and are fully supported in the LMS:

  • Chrome 72+
  • Firefox 64+
  • Safari 10+
  • Microsoft Edge 13+

If you are using a browser version not on this list, we cannot guarantee proper functionality or user experience.

Questions:

If you have specific questions or experience technical issues that cannot be resolved, please visit the PDA LMS Help Center.

NOTE:  In many instances, you can resolve technical issues by clearing web browser cache/cookies.   If you require assistance to complete the steps provided in this link, please consult with your agency's IT department.